fbpx

Important Information Amba System

PLEASE READ THE FOLLOWING INFORMATION BEFORE YOU MAKE YOUR PURCHASE

You will need a Wi-Fi or a 4G mobile hotspot connection.

 

  • The Amba Tablet, provided for the User, has the Amba System installed.

 

  • Member’s devices will need the ‘Amba Care Network’ App from the Apple Store or Google Play. The Amba App works with Android 5.1 or above and IOS 12.0 and above. Before buying, try downloading the ‘Amba Care Network” App from the Store using the Member’s device. If  incompatible the App not appear and a different device will be needed.

 

  • MEMBERS can also login via PC’s, laptops or OLDER tablets at amba.online with their Username and Password.

 

Please Note. On Apple and Windows computers Amba is only certified on FIREFOX and CHROME Browsers.

Google play image
ff